Search Java Classes and Packages

Search Java Frameworks and Libraries

255581 classes and counting ...
Search Tips Index Status



#Javax.crypto.spec Classes and Interfaces - 16 results found.
NameDescriptionTypePackageFramework
DESedeKeySpecThis class specifies a DES-EDE (triple-DES) key.Classjavax.crypto.specJava SE
DESKeySpecThis class specifies a DES key.Classjavax.crypto.specJava SE
DHGenParameterSpecThis class specifies the set of parameters used for generating Diffie-Hellman (system) parameters for use in Diffie-Hellman keyClassjavax.crypto.specJava SE
DHParameterSpecThis class specifies the set of parameters used with the Diffie-Hellman algorithm, as specified in PKCS #3: Diffie-Hellman Key-AgreementClassjavax.crypto.specJava SE
DHPrivateKeySpecThis class specifies a Diffie-Hellman private key with its associated Note that this class does not perform any validation on specifiedClassjavax.crypto.specJava SE
DHPublicKeySpecThis class specifies a Diffie-Hellman public key with its associated Note that this class does not perform any validation on specifiedClassjavax.crypto.specJava SE
GCMParameterSpecSpecifies the set of parameters required by a Cipher using the Galois/Counter Mode (GCM) mode.Classjavax.crypto.specJava SE
IvParameterSpecThis class specifies an initialization vector (IV).Classjavax.crypto.specJava SE
OAEPParameterSpecThis class specifies the set of parameters used with OAEP Padding, Its ASN.Classjavax.crypto.specJava SE
PBEKeySpecA user-chosen password that can be used with password-based encryption The password can be viewed as some kind of raw key material, from whichClassjavax.crypto.specJava SE
PBEParameterSpecThis class specifies the set of parameters used with password-based encryption (PBE), as defined in theClassjavax.crypto.specJava SE
PSourceThis class specifies the source for encoding input P in OAEP Padding, PKCS1PSourceAlgorithms ALGORITHM-IDENTIFIER ::= {Classjavax.crypto.specJava SE
PSource .PSpecifiedThis class is used to explicitly specify the value for encoding input P in OAEP Padding.Classjavax.crypto.spec.PSourceJava SE
RC2ParameterSpecThis class specifies the parameters used with the The parameters consist of an effective key size and optionallyClassjavax.crypto.specJava SE
RC5ParameterSpecThis class specifies the parameters used with the The parameters consist of a version number, a rounds count, a wordClassjavax.crypto.specJava SE
SecretKeySpecThis class specifies a secret key in a provider-independent fashion.Classjavax.crypto.specJava SE